// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^|[^>])(Cass\.\s+com\.(?:,\s+(?:avis|QPC))?,\s+(\d{1,2})e?r?(?:\s| )+(\w+\.?)\s+(\d{4}),\s+n(?:°|°|o)s?(?:\s| )+(\d{2}-\d{2})\.?(\d{3}))").unwrap();
let string = ".Cass. com., 5 janvier 2012, n° 12-45.644";
let substitution = "<renvoi type=\"CASS\" refid=\"$5$6\" jour=\"$2\" mois=\"$3\" annee=\"$4\">$1</renvoi>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}