const regex = /(?:^|[^>])(Cass\.\s+com\.(?:,\s+(?:avis|QPC))?,\s+(\d{1,2})e?r?(?:\s| )+(\w+\.?)\s+(\d{4}),\s+n(?:°|°|o)s?(?:\s| )+(\d{2}-\d{2})\.?(\d{3}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[^>])(Cass\\.\\s+com\\.(?:,\\s+(?:avis|QPC))?,\\s+(\\d{1,2})e?r?(?:\\s| )+(\\w+\\.?)\\s+(\\d{4}),\\s+n(?:°|°|o)s?(?:\\s| )+(\\d{2}-\\d{2})\\.?(\\d{3}))', 'gm')
const str = `.Cass. com., 5 janvier 2012, n° 12-45.644`;
const subst = `<renvoi type="CASS" refid="$5$6" jour="$2" mois="$3" annee="$4">$1</renvoi>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);