$re = '/<br>(.+?)-/';
$str = ' <span class="_c1subtitle _c1">Name<br> 5132 - 0918</span>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);