import Foundation
let pattern = #"<br>(.+?)-"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" <span class="_c1subtitle _c1">Name<br> 5132 - 0918</span>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}