import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\\\\\"(.*)\\\\\"";
final String string = "Hi email@email.com</p>\\n<p>Thanks for showing interest, you can download our PDF with this link below</p>\\n<p><a href=\\\"http://localhost:3000/sales_leads/8/pdf_download\\\">Download PDF</a></p>\\n<p>If you didn't request this, please ignore this email.</p>\\n\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}