import re
regex = re.compile(r"href=\\\"(.*)\\\"")
test_str = ("Hi email@email.com</p>\\n<p>Thanks for showing interest, you can download our PDF with this link below</p>\\n<p><a href=\\\"http://localhost:3000/sales_leads/8/pdf_download\\\">Download PDF</a></p>\\n<p>If you didn't request this, please ignore this email.</p>\\n\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")