$re = '/href=\\\\"(.*)\\\\"/';
$str = 'Hi email@email.com</p>\\n<p>Thanks for showing interest, you can download our PDF with this link below</p>\\n<p><a href=\\"http://localhost:3000/sales_leads/8/pdf_download\\">Download PDF</a></p>\\n<p>If you didn\'t request this, please ignore this email.</p>\\n"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);