const regex = /href=\\"(.*)\\"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=\\\\"(.*)\\\\"', 'g')
const str = `Hi email@email.com</p>\\n<p>Thanks for showing interest, you can download our PDF with this link below</p>\\n<p><a href=\\"http://localhost:3000/sales_leads/8/pdf_download\\">Download PDF</a></p>\\n<p>If you didn't request this, please ignore this email.</p>\\n"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}