package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*([^\s*]|\*\s*[^\sG]|\*\sG[^e]|\*\sGe[^n]|\*\sGen[^e]|\*\sGene[^r]|\*\sGener[^a]|\*\sGenera[^t]|\*\sGenerat[^e]|\*\sGenerate[^d]).*`)
var str = ` * Generated at 2018-11-21
* General
* Green
* This line is important! Although it starts with a *
* This line should be important, but there it contains a "Generated at"...
#define foo
# define bar
return 0;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}