import re
regex = re.compile(r"^\s*([^\s*]|\*\s*[^\sG]|\*\sG[^e]|\*\sGe[^n]|\*\sGen[^e]|\*\sGene[^r]|\*\sGener[^a]|\*\sGenera[^t]|\*\sGenerat[^e]|\*\sGenerate[^d]).*", flags=re.MULTILINE)
test_str = (" * Generated at 2018-11-21\n"
" * General \n"
" * Green \n"
" * This line is important! Although it starts with a * \n"
" * This line should be important, but there it contains a \"Generated at\"...\n"
"#define foo\n"
"# define bar\n"
" return 0;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")