const regex = /^\s*([^\s*]|\*\s*[^\sG]|\*\sG[^e]|\*\sGe[^n]|\*\sGen[^e]|\*\sGene[^r]|\*\sGener[^a]|\*\sGenera[^t]|\*\sGenerat[^e]|\*\sGenerate[^d]).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*([^\\s*]|\\*\\s*[^\\sG]|\\*\\sG[^e]|\\*\\sGe[^n]|\\*\\sGen[^e]|\\*\\sGene[^r]|\\*\\sGener[^a]|\\*\\sGenera[^t]|\\*\\sGenerat[^e]|\\*\\sGenerate[^d]).*', 'gm')
const str = ` * Generated at 2018-11-21
* General
* Green
* This line is important! Although it starts with a *
* This line should be important, but there it contains a "Generated at"...
#define foo
# define bar
return 0;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}