#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=&|^)(?i)key(?-i)=[^&\n]*"
Local $sString = "cool=13&nice=zz&key=value&polo=0" & @CRLF & _
"Key=value&cool=13&nice=zz&polo=0" & @CRLF & _
"cool=13&nice=zz&polo=0&key=value" & @CRLF & _
"" & @CRLF & _
"cool=13&nice=zz&myKey=value&polo=0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")