import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=&|^)(?i)key(?-i)=[^&\\n]*";
final String string = "cool=13&nice=zz&key=value&polo=0\n"
+ "Key=value&cool=13&nice=zz&polo=0\n"
+ "cool=13&nice=zz&polo=0&key=value\n\n"
+ "cool=13&nice=zz&myKey=value&polo=0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}