import re
regex = re.compile(r"(?<=&|^)(?i)key(?-i)=[^&\n]*", flags=re.MULTILINE)
test_str = ("cool=13&nice=zz&key=value&polo=0\n"
"Key=value&cool=13&nice=zz&polo=0\n"
"cool=13&nice=zz&polo=0&key=value\n\n"
"cool=13&nice=zz&myKey=value&polo=0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")