#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?s:.*\n)\K(?:G70|F70|G71|F71).*(\d{5}).*(?:IMPORTO|Prelievo).*(?=(?:G70|G71|F70|F71)\s\d{4}\s\d{5}\s\d{2}\/\d{2}\/\d{4}\s11:11)"
Local $sString = "G70 1234 00012" & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"IMPORTO" & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"F70 1234 00013" & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"Prelievo" & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"F70 1234 00014 10/10/2019 11:11" & @CRLF & _
"...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")