use strict;
my $str = 'G70 1234 00012
....
....
....
....
IMPORTO
....
....
F70 1234 00013
....
....
Prelievo
....
....
F70 1234 00014 10/10/2019 11:11
....';
my $regex = qr/(?s:.*\n)\K(?:G70|F70|G71|F71).*(\d{5}).*(?:IMPORTO|Prelievo).*(?=(?:G70|G71|F70|F71)\s\d{4}\s\d{5}\s\d{2}\/\d{2}\/\d{4}\s11:11)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}