const regex = /(?s:.*\n)\K(?:G70|F70|G71|F71).*(\d{5}).*(?:IMPORTO|Prelievo).*(?=(?:G70|G71|F70|F71)\s\d{4}\s\d{5}\s\d{2}\/\d{2}\/\d{4}\s11:11)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s:.*\\n)\\K(?:G70|F70|G71|F71).*(\\d{5}).*(?:IMPORTO|Prelievo).*(?=(?:G70|G71|F70|F71)\\s\\d{4}\\s\\d{5}\\s\\d{2}\\\/\\d{2}\\\/\\d{4}\\s11:11)', 'gs')
const str = `G70 1234 00012
....
....
....
....
IMPORTO
....
....
F70 1234 00013
....
....
Prelievo
....
....
F70 1234 00014 10/10/2019 11:11
....`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}