import re
regex = re.compile(r"(?s:.*\n)\K(?:G70|F70|G71|F71).*(\d{5}).*(?:IMPORTO|Prelievo).*(?=(?:G70|G71|F70|F71)\s\d{4}\s\d{5}\s\d{2}\/\d{2}\/\d{4}\s11:11)", flags=re.DOTALL)
test_str = ("G70 1234 00012\n"
"....\n"
"....\n"
"....\n"
"....\n"
"IMPORTO\n"
"....\n"
"....\n"
"F70 1234 00013\n"
"....\n"
"....\n"
"Prelievo\n"
"....\n"
"....\n"
"F70 1234 00014 10/10/2019 11:11\n"
"....")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")