import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*/\\*.*?\\*/\\s*)|\\{\\K(?:'[^']*'|\"[^\"]*\"|/\\*.*?\\*/|(?:(?R)|[^\\}]))*";
final String string = "/* {Leading monkeywrench} */\n"
+ "body, html{ overflow-x:hidden; } body{overflow-y:hidden; } header{ position:relative; z-index:2; }\n\n"
+ "body, html{\n"
+ " font-family:'Poppins', sans-serif; /* This will {monkeywrench} */\n"
+ " background-color:white;\n"
+ " overflow-x:hidden;\n"
+ "}\n\n"
+ ".some[selectors-may='contain-a-{'] {\n"
+ " \n"
+ "}\n\n"
+ "@media only screen and (min-width: 200px) {\n"
+ " .test {\n"
+ " prop: val;\n"
+ " }\n"
+ " .test2 {\n"
+ " prop: val;\n"
+ " }\n"
+ "}";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}