const regex = new RegExp('(?:\\s*/\\*.*?\\*/\\s*)|\\{\\K(?:\\'[^\\']*\\'|"[^"]*"|/\\*.*?\\*/|(?:(?R)|[^}]))*', 'g')
const str = `/* {Leading monkeywrench} */
body, html{ overflow-x:hidden; } body{overflow-y:hidden; } header{ position:relative; z-index:2; }
body, html{
font-family:'Poppins', sans-serif; /* This will {monkeywrench} */
background-color:white;
overflow-x:hidden;
}
.some[selectors-may='contain-a-{'] {
}
@media only screen and (min-width: 200px) {
.test {
prop: val;
}
.test2 {
prop: val;
}
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);