$re = '~(?:\s*/\*.*?\*/\s*)|\{\K(?:\'[^\']*\'|"[^"]*"|/\*.*?\*/|(?:(?R)|[^}]))*~';
$str = '/* {Leading monkeywrench} */
body, html{ overflow-x:hidden; } body{overflow-y:hidden; } header{ position:relative; z-index:2; }
body, html{
font-family:\'Poppins\', sans-serif; /* This will {monkeywrench} */
background-color:white;
overflow-x:hidden;
}
.some[selectors-may=\'contain-a-{\'] {
}
@media only screen and (min-width: 200px) {
.test {
prop: val;
}
.test2 {
prop: val;
}
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;