import Foundation
let pattern = #"(?:\s*/\*.*?\*/\s*)|\{\K(?:'[^']*'|"[^"]*"|/\*.*?\*/|(?:(?R)|[^}]))*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/* {Leading monkeywrench} */
body, html{ overflow-x:hidden; } body{overflow-y:hidden; } header{ position:relative; z-index:2; }
body, html{
font-family:'Poppins', sans-serif; /* This will {monkeywrench} */
background-color:white;
overflow-x:hidden;
}
.some[selectors-may='contain-a-{'] {
}
@media only screen and (min-width: 200px) {
.test {
prop: val;
}
.test2 {
prop: val;
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)