using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s*(?:\""([^\""]*)\""|([^;]+))\s*,?)+?";
string input = @"""IP"";""IP_Phys_NET-LG-Facility"";""Facility network at LG"";""192.168.167.0/24"";""IP_Phys_s7362"";""IP_Zone_Network-Transit-Loopback"";;
""Rule"";""Mgmt_AdminVMs"";""Added SV_RDP-UDP -- Mgmt access to any. Can be restricted to OS based rules for virtual destinations as soon as physical and virtual networks are segregated."";""SG_Mgmt_AdminVMs"";""any"";""SV_PING,SV_SSH,SV_PSRemoting,SVG_RDP"";""DISTRIBUTED_FIREWALL"";""Management_AdminVMs"";""allow"";""true"";""false"";""false"";""inout"";""false""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}