// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:\s*(?:\"([^\"]*)\"|([^;]+))\s*,?)+?"#).unwrap();
let string = "\"IP\";\"IP_Phys_NET-LG-Facility\";\"Facility network at LG\";\"192.168.167.0/24\";\"IP_Phys_s7362\";\"IP_Zone_Network-Transit-Loopback\";;
\"Rule\";\"Mgmt_AdminVMs\";\"Added SV_RDP-UDP -- Mgmt access to any. Can be restricted to OS based rules for virtual destinations as soon as physical and virtual networks are segregated.\";\"SG_Mgmt_AdminVMs\";\"any\";\"SV_PING,SV_SSH,SV_PSRemoting,SVG_RDP\";\"DISTRIBUTED_FIREWALL\";\"Management_AdminVMs\";\"allow\";\"true\";\"false\";\"false\";\"inout\";\"false\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}