use strict;
my $str = '"IP";"IP_Phys_NET-LG-Facility";"Facility network at LG";"192.168.167.0/24";"IP_Phys_s7362";"IP_Zone_Network-Transit-Loopback";;
"Rule";"Mgmt_AdminVMs";"Added SV_RDP-UDP -- Mgmt access to any. Can be restricted to OS based rules for virtual destinations as soon as physical and virtual networks are segregated.";"SG_Mgmt_AdminVMs";"any";"SV_PING,SV_SSH,SV_PSRemoting,SVG_RDP";"DISTRIBUTED_FIREWALL";"Management_AdminVMs";"allow";"true";"false";"false";"inout";"false"';
my $regex = qr/(?:\s*(?:\"([^\"]*)\"|([^;]+))\s*,?)+?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}