import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*(?:\\\"([^\\\"]*)\\\"|([^;]+))\\s*,?)+?";
final String string = "\"IP\";\"IP_Phys_NET-LG-Facility\";\"Facility network at LG\";\"192.168.167.0/24\";\"IP_Phys_s7362\";\"IP_Zone_Network-Transit-Loopback\";;\n"
+ "\"Rule\";\"Mgmt_AdminVMs\";\"Added SV_RDP-UDP -- Mgmt access to any. Can be restricted to OS based rules for virtual destinations as soon as physical and virtual networks are segregated.\";\"SG_Mgmt_AdminVMs\";\"any\";\"SV_PING,SV_SSH,SV_PSRemoting,SVG_RDP\";\"DISTRIBUTED_FIREWALL\";\"Management_AdminVMs\";\"allow\";\"true\";\"false\";\"false\";\"inout\";\"false\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}