#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w{10,11}"
Local $sString = "https://www.youtube.com/watch?v=MI9tFPT6yK4&t=17s" & @CRLF & _
"https://www.youtube.com/watch?v=48Y_jWQDDiw" & @CRLF & _
"https://www.youtube.com/MI9tPtdas5" & @CRLF & _
"https://www.youtube.com/9MI9tPtdas5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")