import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w{10,11}";
final String string = "https://www.youtube.com/watch?v=MI9tFPT6yK4&t=17s\n"
+ "https://www.youtube.com/watch?v=48Y_jWQDDiw\n"
+ "https://www.youtube.com/MI9tPtdas5\n"
+ "https://www.youtube.com/9MI9tPtdas5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}