import re
regex = re.compile(r"\w{10,11}")
test_str = ("https://www.youtube.com/watch?v=MI9tFPT6yK4&t=17s\n"
"https://www.youtube.com/watch?v=48Y_jWQDDiw\n"
"https://www.youtube.com/MI9tPtdas5\n"
"https://www.youtube.com/9MI9tPtdas5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")