re = /\w{10,11}/
str = 'https://www.youtube.com/watch?v=MI9tFPT6yK4&t=17s
https://www.youtube.com/watch?v=48Y_jWQDDiw
https://www.youtube.com/MI9tPtdas5
https://www.youtube.com/9MI9tPtdas5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end