#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!){0}([A-Z]{2} [0-9]{7})$"
Local $sString = "AB 1234567" & @CRLF & _
"AAA 1234567" & @CRLF & _
"AB 12345678" & @CRLF & _
"A1 1234567" & @CRLF & _
"AB A123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")