import re
regex = re.compile(r"^(?!){0}([A-Z]{2} [0-9]{7})$", flags=re.MULTILINE)
test_str = ("AB 1234567\n"
"AAA 1234567\n"
"AB 12345678\n"
"A1 1234567\n"
"AB A123456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")