package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\s*p[^>]*>(.*?)<\s*\/\s*p\s*>`)
var str = `<p>I would like <b>all</b> the text!</p> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}