// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<\s*p[^>]*>(.*?)<\s*\/\s*p\s*>").unwrap();
let string = "<p>I would like <b>all</b> the text!</p> ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}