re = /<\s*p[^>]*>(.*?)<\s*\/\s*p\s*>/m
str = '<p>I would like <b>all</b> the text!</p> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end