$re = '/<\s*p[^>]*>(.*?)<\s*\/\s*p\s*>/m';
$str = '<p>I would like <b>all</b> the text!</p> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);