import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<start_date>\\d{4}).*?)?(?<end_date>\\d{4}|(?<=-)\\d{2})?$";
final String string = "May 30, 1949, published 1979\n"
+ "May 30, 1949 and 1951, published 1979\n"
+ "May 30, 1949, printed 1980\n"
+ "May 30, 1949, print executed 1988\n"
+ "May 30, 1949, prints executed 1988\n"
+ "published 1940\n"
+ "August or September 1908\n"
+ "May 30, 1949\n"
+ "May 30, 1949, printed\n"
+ "1920\n"
+ "1920-21";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}