const regex = /((?<start_date>\d{4}).*?)?(?<end_date>\d{4}|(?<=-)\d{2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<start_date>\\d{4}).*?)?(?<end_date>\\d{4}|(?<=-)\\d{2})?$', 'gm')
const str = `May 30, 1949, published 1979
May 30, 1949 and 1951, published 1979
May 30, 1949, printed 1980
May 30, 1949, print executed 1988
May 30, 1949, prints executed 1988
published 1940
August or September 1908
May 30, 1949
May 30, 1949, printed
1920
1920-21`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}