$re = '/((?<start_date>\d{4}).*?)?(?<end_date>\d{4}|(?<=-)\d{2})?$/m';
$str = 'May 30, 1949, published 1979
May 30, 1949 and 1951, published 1979
May 30, 1949, printed 1980
May 30, 1949, print executed 1988
May 30, 1949, prints executed 1988
published 1940
August or September 1908
May 30, 1949
May 30, 1949, printed
1920
1920-21';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);