using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-zA-Z]{3}|\d{2})";
string input = @"lkjskjfeksljf902348798r
jie89382
83nkdkhf
jk8k3jks
09j;lsfdj
.873njdh
ABCkjk
1
2
a
b
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}