import re
regex = re.compile(r"^(?:[a-zA-Z]{3}|\d{2})", flags=re.MULTILINE)
test_str = ("lkjskjfeksljf902348798r\n"
"jie89382\n"
"83nkdkhf\n"
"jk8k3jks\n"
"09j;lsfdj\n"
".873njdh\n"
"ABCkjk\n"
"1\n"
"2\n"
"a\n"
"b\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")