$re = '/^(?:[a-zA-Z]{3}|\d{2})/m';
$str = 'lkjskjfeksljf902348798r
jie89382
83nkdkhf
jk8k3jks
09j;lsfdj
.873njdh
ABCkjk
1
2
a
b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);