re = /^(?:[a-zA-Z]{3}|\d{2})/m
str = 'lkjskjfeksljf902348798r
jie89382
83nkdkhf
jk8k3jks
09j;lsfdj
.873njdh
ABCkjk
1
2
a
b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end