using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^((\d{4}-(((0[13578]|[1][02])-(0[1-9]|[1-2]\d|3[01]))))|((\d{4}-(((0[469]|[1][1])-(0[1-9]|[1-2]\d|[3][0])))))|((\d{4}-(0[2]-(0[1-9]|[1-2]\d)))))T(([01]\d|2[0-3]):([0-5]\d):([0-5]\d))?([+-][0-2]\d:[0-5]\d)$)";
string input = @"2022-02-29T22:58:00+05:30";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}