const regex = /(^((\d{4}-(((0[13578]|[1][02])-(0[1-9]|[1-2]\d|3[01]))))|((\d{4}-(((0[469]|[1][1])-(0[1-9]|[1-2]\d|[3][0])))))|((\d{4}-(0[2]-(0[1-9]|[1-2]\d)))))T(([01]\d|2[0-3]):([0-5]\d):([0-5]\d))?([+-][0-2]\d:[0-5]\d)$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^((\\d{4}-(((0[13578]|[1][02])-(0[1-9]|[1-2]\\d|3[01]))))|((\\d{4}-(((0[469]|[1][1])-(0[1-9]|[1-2]\\d|[3][0])))))|((\\d{4}-(0[2]-(0[1-9]|[1-2]\\d)))))T(([01]\\d|2[0-3]):([0-5]\\d):([0-5]\\d))?([+-][0-2]\\d:[0-5]\\d)$)', 'gm')
const str = `2022-02-29T22:58:00+05:30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}