package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^((\d{4}-(((0[13578]|[1][02])-(0[1-9]|[1-2]\d|3[01]))))|((\d{4}-(((0[469]|[1][1])-(0[1-9]|[1-2]\d|[3][0])))))|((\d{4}-(0[2]-(0[1-9]|[1-2]\d)))))T(([01]\d|2[0-3]):([0-5]\d):([0-5]\d))?([+-][0-2]\d:[0-5]\d)$)`)
var str = `2022-02-29T22:58:00+05:30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}