using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?!\d+\))";
string input = @"Id uniqueidentifier null2,2version varchar(50) null,Modified datetime null,ModifiedBy uniqueidentifier null,Created datetime null,CreatedBy uniqueidentifier null,Folder_Id uniqueidentifier null,Currency_Id uniqueidentifier null,RefCurrency_Id uniqueidentifier null,ValidFrom datetime null,ValidTo datetime null,Rate decimal(28,18) null,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}