use strict;
my $str = 'Id uniqueidentifier null2,2version varchar(50) null,Modified datetime null,ModifiedBy uniqueidentifier null,Created datetime null,CreatedBy uniqueidentifier null,Folder_Id uniqueidentifier null,Currency_Id uniqueidentifier null,RefCurrency_Id uniqueidentifier null,ValidFrom datetime null,ValidTo datetime null,Rate decimal(28,18) null,';
my $regex = qr/,(?!\d+\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}