import Foundation
let pattern = #",(?!\d+\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Id uniqueidentifier null2,2version varchar(50) null,Modified datetime null,ModifiedBy uniqueidentifier null,Created datetime null,CreatedBy uniqueidentifier null,Folder_Id uniqueidentifier null,Currency_Id uniqueidentifier null,RefCurrency_Id uniqueidentifier null,ValidFrom datetime null,ValidTo datetime null,Rate decimal(28,18) null,"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)