const regex = /,(?!\d+\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?!\\d+\\))', 'gm')
const str = `Id uniqueidentifier null2,2version varchar(50) null,Modified datetime null,ModifiedBy uniqueidentifier null,Created datetime null,CreatedBy uniqueidentifier null,Folder_Id uniqueidentifier null,Currency_Id uniqueidentifier null,RefCurrency_Id uniqueidentifier null,ValidFrom datetime null,ValidTo datetime null,Rate decimal(28,18) null,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}